home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / app-misc / ca-certificates-20050804 / ca-certificates-20050804.ebuild < prev    next >
Text File  |  2006-04-25  |  963b  |  37 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/app-misc/ca-certificates/ca-certificates-20050804.ebuild,v 1.3 2006/03/30 14:36:07 flameeyes Exp $
  4.  
  5. inherit eutils
  6.  
  7. DESCRIPTION="Common CA Certificates PEM files"
  8. HOMEPAGE="http://www.cacert.org/"
  9. SRC_URI="mirror://debian/pool/main/c/${PN}/${PN}_${PV}_all.deb"
  10.  
  11. LICENSE="freedist"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
  14. IUSE=""
  15.  
  16. RDEPEND="dev-libs/openssl"
  17.  
  18. S=${WORKDIR}
  19.  
  20. src_unpack() {
  21.     echo ">>> Unpacking ${A} to ${PWD}"
  22.     cp "${DISTDIR}"/${A} .
  23.     ar x ${A} || die "failure unpacking ${A}"
  24. }
  25.  
  26. src_install() {
  27.     cd "${D}"
  28.     tar zxf "${S}"/data.tar.gz || die "installing data failed"
  29.     find "${D}"/usr/share/ca-certificates -name '*.crt' -printf '%P\n' \
  30.         | sort > etc/ca-certificates.conf
  31. }
  32.  
  33. pkg_postinst() {
  34.     [[ ${ROOT} != "/" ]] && return 0
  35.     update-ca-certificates
  36. }
  37.